VMware Fusion < 2.0.6 (VMSA-2009-0013)

High Nessus Plugin ID 41971


The remote host has an application that is affected by two security issues.


The version of VMware Fusion installed on the Mac OS X host is earlier than 2.0.6. Such versions are affected by two security issues :

- A vulnerability in the vmx86 kernel extension allows an unprivileged userland program to initialize several function pointers via the '0x802E564A' IOCTL code, which can lead to arbitrary code execution in the kernel context. (CVE-2009-3281)

- An integer overflow in the vmx86 kernel extension allows for a denial of service of the host by an unprivileged local user. (CVE-2009-3282)


Upgrade to VMware Fusion 2.0.6 or later.

See Also





Plugin Details

Severity: High

ID: 41971

File Name: macosx_fusion_2_0_6.nasl

Version: $Revision: 1.11 $

Type: local

Agent: macosx

Published: 2009/10/02

Modified: 2016/11/28

Dependencies: 50828

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:fusion

Required KB Items: MacOSX/Fusion/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/10/02

Vulnerability Publication Date: 2009/10/02

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-3281, CVE-2009-3282

BID: 36578, 36579

OSVDB: 58475, 58476

CWE: 189, 264