VLC Media Player < 1.0.2 Multiple Remote Buffer Overflows

High Nessus Plugin ID 41626


The remote Windows host contains an application that is affected by multiple remote buffer overflow vulnerabilities.


The version of VLC media player installed on the remote host is earlier than 1.0.2. Such versions are vulnerable to a stack overflow when parsing MP4, ASF, or AVI files with an overly deep box structure.
If an attacker can trick a user into opening a specially crafted MP4, ASF, or AVI file with the affected application, arbitrary code could be executed subject to the user's privileges.


Upgrade to VLC Media Player version 1.0.2 or later.

See Also





Plugin Details

Severity: High

ID: 41626

File Name: vlc_1_0_2.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2009/09/25

Modified: 2014/06/06

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/09/22

Vulnerability Publication Date: 2009/09/17

Reference Information

BID: 36439

OSVDB: 58215, 58216, 58217

Secunia: 36762