Fedora 10 : proftpd-1.3.2a-5.fc10 (2009-9386)

High Nessus Plugin ID 41609


The remote Fedora host is missing a security update.


This update has a large number of changes from previous Fedora packages; the highlights are as follows: - Update to upstream release 1.3.2a - Fix SQL injection vulnerability at login (#485125, CVE-2009-0542) - Fix SELinux compatibility (#498375) - Fix audit logging (#506735) - Fix default configuration (#509251) - Many new loadable modules including mod_ctrls_admin and mod_wrap2 - National Language Support (RFC 2640) - Enable/disable common features in /etc/sysconfig/proftpd

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected proftpd package.

See Also



Plugin Details

Severity: High

ID: 41609

File Name: fedora_2009-9386.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2009/09/25

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:proftpd, cpe:/o:fedoraproject:fedora:10

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/09/09

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2009-0542

BID: 33722

FEDORA: 2009-9386

CWE: 89