Wireshark / Ethereal 0.9.2 to 1.0.9 Multiple Vulnerabilities

Medium Nessus Plugin ID 41029


The remote host has an application that is affected by multiple vulnerabilities.


The installed version of Wireshark or Ethereal is affected by multiple issues :

- The AFS dissector could crash. (Bug 3564)

- The infiniband dissector could crash on some platforms.

- The OpcUa dissector could use excessive CPU and memory.
(Bug 3986)

These vulnerabilities could result in a denial of service. A remote attacker could exploit these issues by tricking a user into opening a maliciously crafted capture file. Additionally, if Wireshark is running in promiscuous mode, one of these issues could be exploited remotely (from the same network segment).


Upgrade to Wireshark 1.0.9 or later.

See Also




Plugin Details

Severity: Medium

ID: 41029

File Name: wireshark_1_0_9.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2009/09/21

Modified: 2016/05/06

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/09/15

Reference Information

CVE: CVE-2009-2562, CVE-2009-2563

BID: 35748

OSVDB: 56017, 56018