Wireshark / Ethereal 0.9.6 to 1.2.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 40999


The remote host has an application that is affected by multiple vulnerabilities.


The installed version of Wireshark or Ethereal is affected by multiple issues :

- The GSM A RR dissector could crash. (Bug 3893)

- The OpcUa dissector could use excessive CPU and memory.
(Bug 3986)

- The TLS dissector could crash on some platforms.
(Bug 4008)

- Wireshark could crash while reading an 'ERF' file. (Bug 3849)

These vulnerabilities could result in a denial of service. A remote attacker could exploit these issues by tricking a user into opening a maliciously crafted capture file. Additionally, if Wireshark is running in promiscuous mode, one of these issues could be exploited remotely (from the same network segment).


Upgrade to Wireshark version 1.2.2 or later.

See Also





Plugin Details

Severity: Medium

ID: 40999

File Name: wireshark_1_2_2.nasl

Version: $Revision: 1.15 $

Type: local

Agent: windows

Family: Windows

Published: 2009/09/16

Modified: 2016/05/06

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/09/15

Vulnerability Publication Date: 2009/09/15

Reference Information

CVE: CVE-2009-3241, CVE-2009-3242, CVE-2009-3243

BID: 36408, 36591

OSVDB: 58157, 58237, 58238

Secunia: 36754