Pidgin < 2.6.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 40986


The remote host has an instant messaging client that is affected by multiple vulnerabilities.


The version of Pidgin installed on the remote host is earlier than 2.6.1. Such versions are reportedly affected by one or more of following issues :

- The Yahoo protocol plugin may crash when receiving an IM from any user that contains a URL. (CVE-2009-3025)

- The XMPP protocol plugin can be tricked into establishing an insecure connection by a malicious man-in-the-middle by causing libpurple to use the older IQ-based login and then not offering TLS/SSL. (CVE-2009-3026)


Upgrade to Pidgin 2.6.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 40986

File Name: pidgin_2_6_1.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2009/09/15

Modified: 2011/08/18

Dependencies: 34205

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:pidgin:pidgin

Required KB Items: SMB/Pidgin/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/08/22

Vulnerability Publication Date: 2009/09/11

Reference Information

CVE: CVE-2009-3025, CVE-2009-3026

BID: 36367, 36368

OSVDB: 57521, 57522

CWE: 310