Mandriva Linux Security Advisory : libsamplerate (MDVSA-2009:232-1)

High Nessus Plugin ID 40968


The remote Mandriva Linux host is missing one or more security updates.


A security vulnerability has been identified and fixed in libsamplerate :

Lev Givon discovered a buffer overflow in libsamplerate that could lead to a segfault with specially crafted python code. This problem has been fixed with libsamplerate-0.1.7 but older versions are affected.

This update provides a solution to this vulnerability.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 40968

File Name: mandriva_MDVSA-2009-232.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/09/14

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64samplerate-devel, p-cpe:/a:mandriva:linux:lib64samplerate0, p-cpe:/a:mandriva:linux:libsamplerate-devel, p-cpe:/a:mandriva:linux:libsamplerate-progs, p-cpe:/a:mandriva:linux:libsamplerate0, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/12/05

Reference Information

MDVSA: 2009:232-1