GLSA-200909-14 : Horde: Multiple vulnerabilities

Medium Nessus Plugin ID 40961

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200909-14 (Horde: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Horde:
Gunnar Wrobel reported an input sanitation and directory traversal flaw in framework/Image/Image.php, related to the 'Horde_Image driver name' (CVE-2009-0932).
Gunnar Wrobel reported that data sent to horde/services/portal/cloud_search.php is not properly sanitized before used in the output (CVE-2009-0931).
It was reported that data sent to framework/Text_Filter/Filter/xss.php is not properly sanitized before used in the output (CVE-2008-5917).
Horde Passwd: David Wharton reported that data sent via the 'backend' parameter to passwd/main.php is not properly sanitized before used in the output (CVE-2009-2360).
Horde IMP: Gunnar Wrobel reported that data sent to smime.php, pgp.php, and message.php is not properly sanitized before used in the output (CVE-2009-0930).
Impact :

A remote authenticated attacker could exploit these vulnerabilities to execute arbitrary PHP files on the server, or disclose the content of arbitrary files, both only if the file is readable to the web server. A remote authenticated attacker could conduct Cross-Site Scripting attacks. NOTE: Some Cross-Site Scripting vectors are limited to the usage of Microsoft Internet Explorer.
Workaround :

There is no known workaround at this time.

Solution

All Horde users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/horde-3.3.4' All Horde IMP users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/horde-imp-4.3.4' All Horde Passwd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/horde-passwd-3.1.1'

See Also

https://security.gentoo.org/glsa/200909-14

Plugin Details

Severity: Medium

ID: 40961

File Name: gentoo_GLSA-200909-14.nasl

Version: 1.18

Type: local

Published: 2009/09/14

Updated: 2019/02/07

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:horde, p-cpe:/a:gentoo:linux:horde-imp, p-cpe:/a:gentoo:linux:horde-passwd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/09/12

Vulnerability Publication Date: 2009/01/20

Exploitable With

CANVAS (D2ExploitPack)

Elliot (Horde < 3.3.2 LFI)

Reference Information

CVE: CVE-2008-5917, CVE-2009-0930, CVE-2009-0931, CVE-2009-0932, CVE-2009-2360

BID: 33491, 33492

GLSA: 200909-14

CWE: 22, 79