Firefox 3.5.x < 3.5.3 Multiple Vulnerabilities

High Nessus Plugin ID 40931


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox 3.5 is earlier than 3.5.3. Such versions are potentially affected by the following security issues :

- Multiple memory corruption vulnerabilities could potentially allow arbitrary code execution. (MFSA 2009-47)

- The columns of a XUL tree element can manipulated in a way that leads to a dangling pointer. A remote attacker could exploit this to crash the browser, or execute arbitrary code. (MFSA 2009-49)

- A URL containing certain Unicode characters with tall tall-line height is displayed incorrectly in the location bar.
A remote attacker could use this to prevent a user from seeing the full URL of a malicious website. (MFSA 2009-50)

- A remote attacker can leverage 'BrowserFeedWriter' to execute JavaScript code with Chrome privileges.
(MFSA 2009-51)


Upgrade to Firefox 3.5.3 or later

See Also

Plugin Details

Severity: High

ID: 40931

File Name: mozilla_firefox_353.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2009/09/10

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/09/09

Vulnerability Publication Date: 2009/09/09

Reference Information

CVE: CVE-2009-3069, CVE-2009-3072, CVE-2009-3073, CVE-2009-3077, CVE-2009-3078, CVE-2009-3079

BID: 36343

OSVDB: 57970, 57972, 57974, 57978, 57979, 57980

Secunia: 36671

CWE: 20, 94