GLSA-200909-06 : aMule: Parameter injection

Medium Nessus Plugin ID 40914


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200909-06 (aMule: Parameter injection)

Sam Hocevar discovered that the aMule preview function does not properly sanitize file names.
Impact :

A remote attacker could entice a user to download a file with a specially crafted file name to inject arbitrary arguments to the victim's video player.
Workaround :

There is no known workaround at this time.


All aMule users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-p2p/amule-2.2.5'

See Also

Plugin Details

Severity: Medium

ID: 40914

File Name: gentoo_GLSA-200909-06.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2009/09/10

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:amule, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/09/09

Reference Information

CVE: CVE-2009-1440

OSVDB: 54179

GLSA: 200909-06