Adobe Acrobat < 9.1.1 / 8.1.5 / 7.1.2 getAnnots() JavaScript Method PDF Handling Memory Corruption (APSB09-06)

High Nessus Plugin ID 40804


The version of Adobe Acrobat on the remote Windows host is affected by a memory corruption vulnerability.


The version of Adobe Acrobat installed on the remote host is earlier than 9.1.1 / 8.1.5 / 7.1.2. Such versions reportedly fail to validate input from a specially crafted PDF file before passing it to the JavaScript method 'getAnnots()' leading to memory corruption and possibly arbitrary code execution.


Upgrade to Adobe Acrobat 9.1.1 / 8.1.5 / 7.1.2 or later.

See Also

Plugin Details

Severity: High

ID: 40804

File Name: adobe_acrobat_911.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2009/08/28

Modified: 2016/11/11

Dependencies: 40797

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat

Required KB Items: SMB/Acrobat/Version

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2009/05/12

Vulnerability Publication Date: 2009/05/01

Reference Information

CVE: CVE-2009-1492

BID: 34736

OSVDB: 54130

CERT: 970180

Secunia: 34924

CWE: 399