Adobe Acrobat < 8.1.2 / 7.1.0 Multiple Vulnerabilities

High Nessus Plugin ID 40800


The version of Adobe Acrobat on the remote Windows host is affected by multiple vulnerabilities.


The version of Adobe Acrobat installed on the remote host is earlier than 8.1.2 or 7.1.0. Such versions are reportedly affected by multiple vulnerabilities :

- A design error vulnerability may allow an attacker to gain control of a user's printer.

- Multiple stack-based buffer overflows may allow an attacker to execute arbitrary code subject to the user's privileges.

- Insecure loading of 'Security Provider' libraries may allow for arbitrary code execution.

- An insecure method exposed by the JavaScript library in the 'EScript.api' plug-in allows direct control over low-level features of the object, which allows for execution of arbitrary code as the current user.

- Two vulnerabilities in the unpublicized function 'app.checkForUpdate()' exploited through a callback function could lead to arbitrary code execution in Adobe Acrobat 7.


Upgrade to Adobe Acrobat 8.1.2 / 7.1.0 or later.

See Also

Plugin Details

Severity: High

ID: 40800

File Name: adobe_acrobat_812.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2009/08/28

Modified: 2016/11/11

Dependencies: 40797

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat

Required KB Items: SMB/Acrobat/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/05/16

Vulnerability Publication Date: 2008/02/07

Exploitable With

Metasploit (Adobe Collab.collectEmailInfo() Buffer Overflow)

Reference Information

CVE: CVE-2007-5659, CVE-2007-5663, CVE-2007-5666, CVE-2008-0655, CVE-2008-0667, CVE-2008-0726, CVE-2008-2042

BID: 27641

OSVDB: 41492, 41493, 41494, 41495, 42683, 44998, 46549

CWE: 94, 119, 189, 399