Fedora 10 : pidgin-2.6.0-1.fc10 (2009-8791)

Critical Nessus Plugin ID 40675


The remote Fedora host is missing a security update.


pidgin upgrade to 2.6.0 for the CVE-2009-2694, insufficient input validation in msn_slplink_process_msg() and numerous other bug fixes.
Fedora 10 does not support voice and video with pidgin-2.6.0. Upgrade to Fedora 11 for this capability.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected pidgin package.

See Also


Plugin Details

Severity: Critical

ID: 40675

File Name: fedora_2009-8791.nasl

Version: $Revision: 1.16 $

Type: local

Agent: unix

Published: 2009/08/24

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:pidgin, cpe:/o:fedoraproject:fedora:10

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/08/20

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-2694

BID: 36071

FEDORA: 2009-8791

CWE: 399