GLSA-200908-10 : Dillo: User-assisted execution of arbitrary code

High Nessus Plugin ID 40635


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200908-10 (Dillo: User-assisted execution of arbitrary code)

Tilei Wang reported an integer overflow in the Png_datainfo_callback() function, possibly leading to a heap-based buffer overflow.
Impact :

A remote attacker could entice a user to open an HTML document containing a specially crafted, large PNG image, possibly resulting in the execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All Dillo users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/dillo-2.1.1'

See Also

Plugin Details

Severity: High

ID: 40635

File Name: gentoo_GLSA-200908-10.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/08/20

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dillo, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/08/18

Reference Information

CVE: CVE-2009-2294

OSVDB: 55656

GLSA: 200908-10

CWE: 189