Mandriva Linux Security Advisory : libxml (MDVSA-2009:200-1)

Medium Nessus Plugin ID 40584

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

Multiple vulnerabilities has been found and corrected in libxml :

Stack consumption vulnerability in libxml2 2.5.10, 2.6.16, 2.6.26, 2.6.27, and 2.6.32, and libxml 1.8.17, allows context-dependent attackers to cause a denial of service (application crash) via a large depth of element declarations in a DTD, related to a function recursion, as demonstrated by the Codenomicon XML fuzzing framework (CVE-2009-2414).

Multiple use-after-free vulnerabilities in libxml2 2.5.10, 2.6.16, 2.6.26, 2.6.27, and 2.6.32, and libxml 1.8.17, allow context-dependent attackers to cause a denial of service (application crash) via crafted (1) Notation or (2) Enumeration attribute types in an XML file, as demonstrated by the Codenomicon XML fuzzing framework (CVE-2009-2416).

This update provides a solution to these vulnerabilities.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers

Solution

Update the affected packages.

Plugin Details

Severity: Medium

ID: 40584

File Name: mandriva_MDVSA-2009-200.nasl

Version: 1.24

Type: local

Published: 2009/08/13

Updated: 2018/07/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64xml1, p-cpe:/a:mandriva:linux:lib64xml1-devel, p-cpe:/a:mandriva:linux:lib64xml2-devel, p-cpe:/a:mandriva:linux:lib64xml2_2, p-cpe:/a:mandriva:linux:libxml1, p-cpe:/a:mandriva:linux:libxml1-devel, p-cpe:/a:mandriva:linux:libxml2-devel, p-cpe:/a:mandriva:linux:libxml2-python, p-cpe:/a:mandriva:linux:libxml2-utils, p-cpe:/a:mandriva:linux:libxml2_2, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/04

Reference Information

CVE: CVE-2009-2414, CVE-2009-2416

BID: 36010

MDVSA: 2009:200-1

CWE: 119, 399