MS09-041: Vulnerability in Workstation Service Could Allow Elevation of Privilege (971657)

High Nessus Plugin ID 40560


Users can elevate their privileges on the remote host.


The remote host contains a version of the 'Workstation' service that contains a memory corruption vulnerability that might allow an attacker with valid credentials to execute arbitrary code on the remote host.


Microsoft has released a set of patches for Windows XP, 2003, Vista and Server 2008.

See Also

Plugin Details

Severity: High

ID: 40560

File Name: smb_nt_ms09-041.nasl

Version: $Revision: 1.18 $

Type: local

Agent: windows

Published: 2009/08/11

Modified: 2017/08/09

Dependencies: 13855, 57033

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/08/11

Vulnerability Publication Date: 2009/08/11

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-1544

BID: 35972

OSVDB: 56902

MSFT: MS09-041

MSKB: 971657

IAVB: 2009-B-0035

CWE: 399