Mac OS X : GarageBand < 5.1

Medium Nessus Plugin ID 40480


The remote host has a version of GarageBand that is affected by an information disclosure vulnerability.


The remote Mac OS X 10.5 host is running a version of GarageBand older than 5.1. When such versions are opened, Safari's preferences are changed from the default setting to accept cookies only for the sites being visited to always except cookies. This change may allow third-parties, in particular advertisers, to track a user's browsing activity.


Upgrade to GarageBand 5.1 or later and check that Safari's preferences are set as desired.

See Also

Plugin Details

Severity: Medium

ID: 40480

File Name: macosx_garageband_5_1.nasl

Version: 1.9

Type: local

Agent: macosx

Published: 2009/08/04

Modified: 2017/05/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Required KB Items: Host/MacOSX/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/08/03

Vulnerability Publication Date: 2009/08/03

Reference Information

CVE: CVE-2009-2198

BID: 35926

OSVDB: 56738

CWE: 264