Firefox 3.5.x < 3.5.2 Multiple Vulnerabilities

High Nessus Plugin ID 40479


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox 3.5 is earlier than 3.5.2. Such versions are potentially affected by the following security issues :

- A SOCKS5 proxy that replies with a hostname containing more than 15 characters can corrupt the subsequent data stream. This can lead to a denial of service, though there is reportedly no memory corruption.
(MFSA 2009-38)

- The location bar and SSL indicators can be spoofed by calling on an invalid URL. A remote attacker could use this to perform a phishing attack.
(MFSA 2009-44)

- Unspecified JavaScript-related vulnerabilities can lead to memory corruption, and possibly arbitrary execution of code. (MFSA 2009-45, MFSA 2009-47)

- If an add-on has a 'Link:' HTTP header when it is installed, the window's global object receives an incorrect security wrapper, which could lead to arbitrary JavaScript being executed with chrome privileges. (MFSA 2009-46)


Upgrade to Firefox 3.5.2 or later.

See Also

Plugin Details

Severity: High

ID: 40479

File Name: mozilla_firefox_352.nasl

Version: $Revision: 1.17 $

Type: local

Agent: windows

Family: Windows

Published: 2009/08/04

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/07/21

Reference Information

CVE: CVE-2009-2654, CVE-2009-2470, CVE-2009-2662, CVE-2009-2663, CVE-2009-2664, CVE-2009-2665, CVE-2009-3071, CVE-2009-3075

BID: 35803, 35925, 35927, 35928, 36018, 36343

OSVDB: 56716, 56717, 56718, 56719, 56720, 56721, 56722, 57973, 57976

Secunia: 36001

CWE: 20, 94, 119, 399