MS09-035: Vulnerabilities in Visual Studio Active Template Library Could Allow Remote Code Execution (969706)

High Nessus Plugin ID 40435

Synopsis

Arbitrary code can be executed on the remote host through Microsoft Active Template Library.

Description

The remote Windows host contains a version of the Microsoft Active Template Library (ATL), included as part of Visual Studio or Visual C++, that is affected by multiple vulnerabilities :

- On systems with components and controls installed that were built using Visual Studio ATL, an issue in the ATL headers could allow an attacker to force VariantClear to be called on a VARIANT that has not been correctly initialized and, by supplying a corrupt stream, to execute arbitrary code. (CVE-2009-0901)

- On systems with components and controls installed that were built using Visual Studio ATL, unsafe usage of OleLoadFromStream could allow instantiation of arbitrary objects that can bypass related security policy, such as kill bits within Internet Explorer.
(CVE-2009-2493)

- On systems with components and controls installed that were built using Visual Studio ATL, an issue in the ATL headers could allow a string to be read without a terminating NULL character, which could lead to disclosure of information in memory. (CVE-2009-2495)

Solution

Microsoft has released a set of patches for Visual Studio .NET 2003, Visual Studio 2005 and 2008, as well as Visual C++ 2005 and 2008.

See Also

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2009/ms09-035

Plugin Details

Severity: High

ID: 40435

File Name: smb_nt_ms09-035.nasl

Version: 1.32

Type: local

Agent: windows

Published: 2009/07/30

Updated: 2018/11/15

Dependencies: 13855, 57033

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:visual_studio, cpe:/a:microsoft:visual_studio_.net, cpe:/a:microsoft:visual_c++

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/07/28

Vulnerability Publication Date: 2009/07/28

Reference Information

CVE: CVE-2009-0901, CVE-2009-2493, CVE-2009-2495

BID: 35828, 35830, 35832

MSFT: MS09-035

MSKB: 973544, 973551, 973552, 973675

IAVB: 2009-B-0033

CERT: 456745

CWE: 94, 200, 264