Mandriva Linux Security Advisory : initscripts (MDVSA-2009:170)

High Nessus Plugin ID 40415


The remote Mandriva Linux host is missing one or more security updates.


Mandriva Security team has identified and fixed a vulnerability in initscripts which could lead to partial wireless password disclosure for WPA/WPA2 passwords of certain length which contained spaces.

This update fixes the vulnerability.


Update the affected debugmode and / or initscripts packages.

See Also

Plugin Details

Severity: High

ID: 40415

File Name: mandriva_MDVSA-2009-170.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2009/07/29

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:debugmode, p-cpe:/a:mandriva:linux:initscripts, cpe:/o:mandriva:linux:2008.1, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2009.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/07/28

Reference Information

MDVSA: 2009:170