Google Chrome < Multiple Vulnerabilities

High Nessus Plugin ID 39852


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than Such versions are reportedly affected by multiple issues :

- A heap overflow exists when evaluating specially crafted regular expressions in JavaScript. This could lead to a denial of service or the execution of arbitrary code within the Google Chrome sandbox. (Issue 14719)

- A memory corruption issue exists in the renderer process that could cause a denial of service or possibly allow arbitrary code execution with the privileges of the logged on user. (CVE-2009-2556)

- Creating a Select object with a very large length can result in memory exhaustion, causing a denial of service.


Upgrade to Google Chrome or later.

See Also

Plugin Details

Severity: High

ID: 39852

File Name: google_chrome_2_0_172_37.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2009/07/17

Modified: 2016/11/11

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/07/16

Vulnerability Publication Date: 2009/07/16

Reference Information

CVE: CVE-2009-1692, CVE-2009-2555, CVE-2009-2556

BID: 35446, 35722, 35723

OSVDB: 55242, 55939, 56245

Secunia: 35844

CWE: 119, 399