Samba < 3.0.35 / 3.2.13 / 3.3.6 Multiple Vulnerabilities

Low Nessus Plugin ID 39502


The remote Samba server may be affected by a security bypass vulnerability.


According to its version number, the version of Samba running on the remote host has a security bypass vulnerability. Access restrictions can be bypassed due to a read of uninitialized data in smbd. This could allow a user to modify an access control list (ACL), even when they should be denied permission.

Note the 'dos filemode' parameter must be set to 'yes' in smb.conf in order for an attack to be successful (the default setting is 'no').

Also note versions 3.2.0 - 3.2.12 of smbclient are affected by a format string vulnerability, though Nessus has not checked for this.


Upgrade to Samba version 3.3.6 / 3.2.13 / 3.0.35 or later, or apply the appropriate patch referenced in the vendor's advisory.

See Also

Plugin Details

Severity: Low

ID: 39502

File Name: samba_acl_security_bypass.nasl

Version: $Revision: 1.13 $

Type: remote

Family: Misc.

Published: 2009/06/24

Modified: 2016/12/14

Dependencies: 10785

Risk Information

Risk Factor: Low


Base Score: 3.5

Temporal Score: 2.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/samba, SMB/NativeLanManager

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2006/07/10

Reference Information

CVE: CVE-2009-1886, CVE-2009-1888, CVE-2006-3403

BID: 35472

OSVDB: 27130, 55411, 55412

Secunia: 35539

CWE: 134, 264