Google Chrome < Multiple Vulnerabilities

Medium Nessus Plugin ID 39449


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than Such versions are reportedly affected by multiple vulnerabilities :

- The browser uses the HTTP Host header to determine the context of a 4xx/5xx CONNECT response from a proxy server. This could allow a man-in-the-middle attacker to execute arbitrary script code in the context of a legitimate server, circumventing the browser's same- origin policy.

- The browser displays a cached certificate for 4xx/5xx CONNECT response pages from a proxy server. A man-in- the-middle attacker could exploit this by displaying a spoofed web page with the valid certificate of a legitimate website.


Upgrade to Google Chrome or later.

See Also

Plugin Details

Severity: Medium

ID: 39449

File Name: google_chrome_1_0_154_53.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2009/06/19

Modified: 2016/05/16

Dependencies: 34196

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2009-2060, CVE-2009-2071

BID: 35380, 35411

OSVDB: 55132, 56488

CWE: 287