Firefox < 3.0.11 Multiple Vulnerabilities

High Nessus Plugin ID 39372


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox is earlier than 3.0.11. Such versions are potentially affected by the following security issues :

- Multiple memory corruption vulnerabilities could potentially be exploited to execute arbitrary code. (MFSA 2009-24)

- Certain invalid Unicode characters, when used as a part of IDN, can be displayed as a whitespace in the location bar. An attacker could exploit this vulnerability to spoof the location bar. (MFSA 2009-25)

- It may be possible for local resources loaded via 'file:' protocol to access any domain's cookies saved on a user's system. (MFSA 2009-26)

- It may be possible to tamper with SSL data via non-200 responses to proxy CONNECT requests. (MFSA 2009-27)

- A race condition exists in 'NPObjWrapper_NewResolve' when accessing the properties of a NPObject, a wrapped JSObject. This flaw could be potentially exploited to execute arbitrary code on the remote system. (MFSA 2009-28)

- If the owner document of an element becomes null after garbage collection, then it may be possible to execute the event listeners within the wrong JavaScript context.
An attacker could potentially exploit this vulnerability to execute arbitrary JavaScript with chrome privileges.
(MFSA 2009-29)

- When the 'file:' resource is loaded from the location bar, the resource inherits the principal of the previously loaded document. This could potentially allow unauthorized access to local files. (MFSA 2009-30)

- While loading external scripts into XUL documents content-loading policies are not checked. (MFSA 2009-31)

- It may be possible for scripts from page content to run with elevated privileges. (MFSA 2009-32)


Upgrade to Firefox 3.0.11 or later.

See Also

Plugin Details

Severity: High

ID: 39372

File Name: mozilla_firefox_3011.nasl

Version: 1.23

Type: local

Agent: windows

Family: Windows

Published: 2009/06/12

Updated: 2018/11/15

Dependencies: 20862

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/06/11

Reference Information

CVE: CVE-2009-1392, CVE-2009-1832, CVE-2009-1833, CVE-2009-1834, CVE-2009-1835, CVE-2009-1836, CVE-2009-1837, CVE-2009-1838, CVE-2009-1839, CVE-2009-1840, CVE-2009-1841

BID: 35360, 35370, 35371, 35372, 35373, 35377, 35380, 35383, 35386, 35388, 35391

Secunia: 35331

CWE: 20, 94, 200, 264, 287, 362