Google Chrome < 2.0.172.31 WebKit Multiple Vulnerabilities

medium Nessus Plugin ID 39356
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is earlier than 2.0.172.31. It thus is reportedly affected by multiple issues :

- A memory corruption issue exists in the way the WebKit handles recursion in certain DOM event handlers.
Successful exploitation of this issue could allow arbitrary code execution within the Google Chrome sandbox. (CVE-2009-1690)

- WebKit's handling of drag events is affected by an information disclosure issue. (CVE-2009-1718)

Solution

Upgrade to Google Chrome 2.0.172.31 or later.

See Also

http://www.nessus.org/u?364bcb10

Plugin Details

Severity: Medium

ID: 39356

File Name: google_chrome_2_0_172_31.nasl

Version: 1.15

Type: local

Agent: windows

Family: Windows

Published: 6/11/2009

Updated: 11/15/2018

Dependencies: google_chrome_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 6/9/2009

Reference Information

CVE: CVE-2009-1690, CVE-2009-1718

BID: 35271, 35272

Secunia: 35411

CWE: 200, 399