Adobe Reader < 9.1.2 / 8.1.6 / 7.1.3 Multiple Vulnerabilities

high Nessus Plugin ID 39355

Synopsis

The PDF file viewer on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Reader installed on the remote host is earlier than 9.1.2 / 8.1.6 / 7.1.3. Such versions are reportedly affected by multiple vulnerabilities :

- A stack-based buffer overflow can lead to code execution.
(CVE-2009-1855)

- An integer buffer overflow can result in an application crash and possibly code execution, although that has not been shown yet. (CVE-2009-1856)

- A memory corruption issue can result in an application crash and possibly code execution, although that has not been shown yet. (CVE-2009-1857)

- A memory corruption issue in the JBIG2 filter can lead to code execution. (CVE-2009-1858)

- A memory corruption issue can lead to code execution.
(CVE-2009-1859)

- A memory corruption issue in the JBIG2 filter can result in an application crash and possibly code execution, although that has not been shown yet.
(CVE-2009-0198)

- Multiple heap-based buffer overflow vulnerabilities in the JBIG2 filter can lead to code execution.
(CVE-2009-0509, CVE-2009-0510, CVE-2009-0511, CVE-2009-0512, CVE-2009-0888, CVE-2009-0889)

- Multiple heap-based buffer overflow vulnerabilities can lead to code execution. (CVE-2009-1861)

Solution

Upgrade to Adobe Reader 9.1.2 / 8.1.6 / 7.1.3 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb09-07.html

Plugin Details

Severity: High

ID: 39355

File Name: adobe_reader_912.nasl

Version: 1.23

Type: local

Agent: windows

Family: Windows

Published: 6/11/2009

Updated: 6/27/2018

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/9/2009

Reference Information

CVE: CVE-2009-0198, CVE-2009-0509, CVE-2009-0510, CVE-2009-0511, CVE-2009-0512, CVE-2009-0888, CVE-2009-0889, CVE-2009-1855, CVE-2009-1856, CVE-2009-1857, CVE-2009-1858, CVE-2009-1859, CVE-2009-1861

BID: 35274, 35282, 35289, 35291, 35293, 35294, 35295, 35296, 35298, 35299, 35300, 35301, 35302, 35303

CWE: 119, 189, 399