MS09-022: Vulnerabilities in Windows Print Spooler Could Allow Remote Code Execution (961501)

Critical Nessus Plugin ID 39344


Arbitrary code can be executed on the remote host due to a flaw in the Spooler service.


The version of the Print Spooler service on the remote Windows host is affected by one or more of the following vulnerabilities :

- A buffer overflow vulnerability could allow an unauthenticated, remote attacker to execute arbitrary code with SYSTEM privileges. (CVE-2009-0228)

- Using a specially crafted separator page, a local user can read or print any file on the affected system.

- Using a specially crafted RPC message, a user who has the 'Manage Printer' privilege can have the spooler load an arbitrary DLL and thereby execute arbitrary code with elevated privileges. (CVE-2009-0230)


Microsoft has released a set of patches for Windows 2000, XP, 2003, Vista and 2008.

See Also

Plugin Details

Severity: Critical

ID: 39344

File Name: smb_nt_ms09-022.nasl

Version: $Revision: 1.22 $

Type: local

Agent: windows

Published: 2009/06/10

Modified: 2017/08/09

Dependencies: 57033, 13855

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/06/09

Vulnerability Publication Date: 2009/06/09

Exploitable With


Core Impact

Reference Information

CVE: CVE-2009-0228, CVE-2009-0229, CVE-2009-0230

BID: 35206, 35208, 35209

OSVDB: 54932, 54933, 54934

MSFT: MS09-022

MSKB: 961501

CWE: 119, 200, 264