Sun Java System Directory Server Online Help Feature Information Disclosure

medium Nessus Plugin ID 39314
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running a web application that is affected by an information disclosure vulnerability.

Description

Sun Java System Directory Server is running on the remote web server. The hosted version is affected by an information disclosure vulnerability. By sending a specially crafted request to the online help feature, it is possible for a remote attacker to determine if certain files exist, and in some cases retrieve a single line from files.

Solution

Either disable the online help or upgrade to Sun Java System Directory Server Enterprise Edition 6.0 or later as discussed in the vendor's advisory.

See Also

https://download.oracle.com/sunalerts/1020302.1.html

Plugin Details

Severity: Medium

ID: 39314

File Name: sun_ds_help_info_disclosure.nasl

Version: 1.16

Type: remote

Family: CGI abuses

Published: 6/4/2009

Updated: 1/19/2021

Dependencies: http_version.nasl

Risk Information

VPR

Risk Factor: Low

Score: 2.5

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Exploited by Nessus: true

Patch Publication Date: 4/15/2009

Reference Information

CVE: CVE-2009-1332

BID: 34548

Secunia: 34751