Mandriva Linux Security Advisory : cyrus-sasl (MDVSA-2009:113-1)

High Nessus Plugin ID 38814

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

Multiple buffer overflows in the CMU Cyrus SASL library before 2.1.23 might allow remote attackers to execute arbitrary code or cause a denial of service application crash) via strings that are used as input to the sasl_encode64 function in lib/saslutil.c (CVE-2009-0688).

The updated packages have been patched to prevent this.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers

Solution

Update the affected packages.

Plugin Details

Severity: High

ID: 38814

File Name: mandriva_MDVSA-2009-113.nasl

Version: 1.15

Type: local

Published: 2009/05/19

Updated: 2018/07/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cyrus-sasl, p-cpe:/a:mandriva:linux:lib64sasl2, p-cpe:/a:mandriva:linux:lib64sasl2-devel, p-cpe:/a:mandriva:linux:lib64sasl2-plug-anonymous, p-cpe:/a:mandriva:linux:lib64sasl2-plug-crammd5, p-cpe:/a:mandriva:linux:lib64sasl2-plug-digestmd5, p-cpe:/a:mandriva:linux:lib64sasl2-plug-gssapi, p-cpe:/a:mandriva:linux:lib64sasl2-plug-ldapdb, p-cpe:/a:mandriva:linux:lib64sasl2-plug-login, p-cpe:/a:mandriva:linux:lib64sasl2-plug-ntlm, p-cpe:/a:mandriva:linux:lib64sasl2-plug-otp, p-cpe:/a:mandriva:linux:lib64sasl2-plug-plain, p-cpe:/a:mandriva:linux:lib64sasl2-plug-sasldb, p-cpe:/a:mandriva:linux:lib64sasl2-plug-sql, p-cpe:/a:mandriva:linux:libsasl2, p-cpe:/a:mandriva:linux:libsasl2-devel, p-cpe:/a:mandriva:linux:libsasl2-plug-anonymous, p-cpe:/a:mandriva:linux:libsasl2-plug-crammd5, p-cpe:/a:mandriva:linux:libsasl2-plug-digestmd5, p-cpe:/a:mandriva:linux:libsasl2-plug-gssapi, p-cpe:/a:mandriva:linux:libsasl2-plug-ldapdb, p-cpe:/a:mandriva:linux:libsasl2-plug-login, p-cpe:/a:mandriva:linux:libsasl2-plug-ntlm, p-cpe:/a:mandriva:linux:libsasl2-plug-otp, p-cpe:/a:mandriva:linux:libsasl2-plug-plain, p-cpe:/a:mandriva:linux:libsasl2-plug-sasldb, p-cpe:/a:mandriva:linux:libsasl2-plug-sql, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/12/03

Reference Information

CVE: CVE-2009-0688

MDVSA: 2009:113-1

CWE: 119