Google Chrome < 1.0.154.65 WebKit SVGList Object Handling Memory Corruption

medium Nessus Plugin ID 38791
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by a remote code execution vulnerability.

Description

The version of Google Chrome installed on the remote host is earlier than 1.0.154.65. Such versions are reportedly affected by a memory corruption issue. An attacker could exploit this flaw in order to run arbitrary code inside the Google Chrome sandbox.

Solution

Upgrade to Google Chrome 1.0.154.65 or later.

See Also

http://www.nessus.org/u?c9adf2dd

Plugin Details

Severity: Medium

ID: 38791

File Name: google_chrome_1_0_154_65.nasl

Version: 1.12

Type: local

Agent: windows

Family: Windows

Published: 5/15/2009

Updated: 11/15/2018

Dependencies: google_chrome_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 5/7/2009

Reference Information

CVE: CVE-2009-0945

BID: 34924

CWE: 94