Safari < 3.2.3 Multiple Vulnerabilities

High Nessus Plugin ID 38745


The remote host contains a web browser that is affected by several vulnerabilities.


The version of Safari installed on the remote Windows host is earlier than 3.2.3. Such versions are potentially affected by several issues :

- A heap-based buffer overflow issue in the libxml library when handling long entity names could lead to a crash or arbitrary code execution. (CVE-2008-3529)

- Multiple input validation issues exist in Safari's handling of 'feed:' URLs, which could be abused to execute arbitrary JavaScript code. (CVE-2009-0162)

- A memory corruption issue in WebKit's handling of SVGList objects could lead to arbitrary code execution.

- The browser uses the HTTP Host header to determine the context of a 4xx/5xx CONNECT response from a proxy server.
This could allow a man-in-the-middle attacker to execute arbitrary script code in the context of a legitimate server, circumventing the browser's same-origin policy. (CVE-2009-2058)


Upgrade to Safari 3.2.3 or later.

See Also

Plugin Details

Severity: High

ID: 38745

File Name: safari_3_2_3.nasl

Version: $Revision: 1.15 $

Type: local

Agent: windows

Family: Windows

Published: 2009/05/13

Modified: 2016/12/14

Dependencies: 31788

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: SMB/Safari/FileVersion

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2008-3529, CVE-2009-0162, CVE-2009-0945, CVE-2009-2058

BID: 31126, 34924, 34925, 35380

OSVDB: 48158, 54454, 54455, 55130

Secunia: 35056

CWE: 79, 94, 119, 287