RHEL 3 / 4 / 5 : pango (RHSA-2009:0476)

Medium Nessus Plugin ID 38732


The remote Red Hat host is missing one or more security updates.


Updated pango and evolution28-pango packages that fix an integer overflow flaw are now available for Red Hat Enterprise Linux 3, 4, and 5.

This update has been rated as having important security impact by the Red Hat Security Response Team.

Pango is a library used for the layout and rendering of internationalized text.

Will Drewry discovered an integer overflow flaw in Pango's pango_glyph_string_set_size() function. If an attacker is able to pass an arbitrarily long string to Pango, it may be possible to execute arbitrary code with the permissions of the application calling Pango.

pango and evolution28-pango users are advised to upgrade to these updated packages, which contain a backported patch to resolve this issue. After installing this update, you must restart your system or restart the X server for the update to take effect. Note: Restarting the X server closes all open applications and logs you out of your session.


Update the affected packages.

See Also



Plugin Details

Severity: Medium

ID: 38732

File Name: redhat-RHSA-2009-0476.nasl

Version: $Revision: 1.20 $

Type: local

Agent: unix

Published: 2009/05/11

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:evolution28-pango, p-cpe:/a:redhat:enterprise_linux:evolution28-pango-devel, p-cpe:/a:redhat:enterprise_linux:pango, p-cpe:/a:redhat:enterprise_linux:pango-devel, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:4.7, cpe:/o:redhat:enterprise_linux:5, cpe:/o:redhat:enterprise_linux:5.3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/05/08

Reference Information

CVE: CVE-2009-1194

BID: 34870

OSVDB: 54279

RHSA: 2009:0476

CWE: 189