Citrix Web Interface 4.6 / 5.0 / 5.0.1 Unspecified XSS

medium Nessus Plugin ID 38663
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host contains a web application that is affected by a cross-site scripting vulnerability.


The remote host contains a version of Citrix Web Interface earlier than 5.1.0. As such, it reportedly is affected by an as-yet unspecified cross-site scripting vulnerability. An attacker could exploit this issue to steal cookie-based authentication and launch other attacks.


Upgrade to Citrix Web Interface 5.1.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 38663

File Name: citrix_web_interface_xss.nasl

Version: 1.18

Type: local

Agent: windows

Family: Windows

Published: 5/1/2009

Updated: 11/15/2018

Dependencies: smb_hotfixes.nasl

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:citrix:web_interface

Required KB Items: SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 4/21/2009

Reference Information

CVE: CVE-2009-2454

BID: 34761

Secunia: 34868

CWE: 79