Firefox < 3.0.10 Multiple Vulnerabilities

High Nessus Plugin ID 38200


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The version of Firefox installed on the remote host is earlier than 3.0.10. Such versions have multiple vulnerabilities :

- An error in function '@nsTextFrame::ClearTextRun()' could corrupt the memory. Successful exploitation of this issue may allow arbitrary code execution on the remote system. Note this reportedly only affects 3.0.9. (MFSA 2009-23)

- The browser processes a 3xx HTTP CONNECT response before a successful SSL handshake, which could allow a man-in- the-middle attacker to execute arbitrary web script in the context of a HTTPS server. (CVE-2009-2061)


Upgrade to Firefox 3.0.10 or later.

See Also

Plugin Details

Severity: High

ID: 38200

File Name: mozilla_firefox_3010.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2009/04/28

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/27

Reference Information

CVE: CVE-2009-1313, CVE-2009-2061

BID: 34743, 35412

OSVDB: 54174, 55133

Secunia: 34866

CWE: 310, 399