Firefox < 3.0.10 Multiple Vulnerabilities

high Nessus Plugin ID 38200
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The version of Firefox installed on the remote host is earlier than 3.0.10. Such versions have multiple vulnerabilities :

- An error in function '@nsTextFrame::ClearTextRun()' could corrupt the memory. Successful exploitation of this issue may allow arbitrary code execution on the remote system. Note this reportedly only affects 3.0.9. (MFSA 2009-23)

- The browser processes a 3xx HTTP CONNECT response before a successful SSL handshake, which could allow a man-in- the-middle attacker to execute arbitrary web script in the context of a HTTPS server. (CVE-2009-2061)


Upgrade to Firefox 3.0.10 or later.

See Also

Plugin Details

Severity: High

ID: 38200

File Name: mozilla_firefox_3010.nasl

Version: 1.18

Type: local

Agent: windows

Family: Windows

Published: 4/28/2009

Updated: 11/15/2018

Dependencies: mozilla_org_installed.nasl

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/27/2009

Reference Information

CVE: CVE-2009-1313, CVE-2009-2061

BID: 34743, 35412

Secunia: 34866

CWE: 310, 399