Mandriva Linux Security Advisory : vinagre (MDVSA-2008:240)

Medium Nessus Plugin ID 38069


The remote Mandriva Linux host is missing a security update.


Alfredo Ortega found a flaw in how Vinagre uses format strings. A remote attacker could exploit this vulnerability if they were able to trick a user into connecting to a malicious VNC server, or opening a specially crafted URI with Vinagre. With older versions of Vinagre, it was possible to execute arbitrary code with user privileges. In later versions, Vinagre would abort, leading to a denial of service.

The updated packages have been patched to prevent this issue.


Update the affected vinagre package.

Plugin Details

Severity: Medium

ID: 38069

File Name: mandriva_MDVSA-2008-240.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:vinagre, cpe:/o:mandriva:linux:2008.1, cpe:/o:mandriva:linux:2009.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/12/10

Reference Information

CVE: CVE-2008-5660

BID: 32682

MDVSA: 2008:240

CWE: 134