Mandriva Linux Security Advisory : ntp (MDVSA-2009:092)

Medium Nessus Plugin ID 37998


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in ntp :

Requesting peer information from a malicious remote time server may lead to an unexpected application termination or arbitrary code execution (CVE-2009-0159).

The updated packages have been patched to correct this issue.


Update the affected ntp, ntp-client and / or ntp-doc packages.

Plugin Details

Severity: Medium

ID: 37998

File Name: mandriva_MDVSA-2009-092.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2009/04/23

Modified: 2014/11/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ntp, p-cpe:/a:mandriva:linux:ntp-client, p-cpe:/a:mandriva:linux:ntp-doc, cpe:/o:mandriva:linux:2008.1, cpe:/o:mandriva:linux:2009.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/04/13

Reference Information

CVE: CVE-2009-0159

BID: 34481

MDVSA: 2009:092

CWE: 119