Mandriva Linux Security Advisory : libsndfile (MDVSA-2009:067)

High Nessus Plugin ID 37704


The remote Mandriva Linux host is missing one or more security updates.


Crafted data - channels per frame value - in CAF files enables remote attackers to execute arbitrary code or denial of service via a possible integer overflow, leading to a possible heap overflow (CVE-2009-0186).

This update provides fix for that vulnerability.


Update the affected packages.

Plugin Details

Severity: High

ID: 37704

File Name: mandriva_MDVSA-2009-067.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64sndfile-devel, p-cpe:/a:mandriva:linux:lib64sndfile-static-devel, p-cpe:/a:mandriva:linux:lib64sndfile1, p-cpe:/a:mandriva:linux:libsndfile-devel, p-cpe:/a:mandriva:linux:libsndfile-progs, p-cpe:/a:mandriva:linux:libsndfile-static-devel, p-cpe:/a:mandriva:linux:libsndfile1, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1, cpe:/o:mandriva:linux:2009.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/03/05

Reference Information

CVE: CVE-2009-0186

BID: 33963

MDVSA: 2009:067

CWE: 189