Mandriva Linux Security Advisory : unzip (MDVSA-2008:068)

High Nessus Plugin ID 37575


The remote Mandriva Linux host is missing a security update.


Tavis Ormandy of Google Security discovered an invalid pointer flaw in unzip that could lead to the execution of arbitrary code with the privileges of the user running unzip.

The updated packages have been patched to correct this issue.


Update the affected unzip package.

Plugin Details

Severity: High

ID: 37575

File Name: mandriva_MDVSA-2008-068.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:unzip, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/03/18

Reference Information

CVE: CVE-2008-0888

BID: 28288

MDVSA: 2008:068

CWE: 119