Kibana 9.0.x < 9.4.9 / 9.5.x < 9.5.6 RCE (ESA-2026-232)

critical Nessus Plugin ID 375645

Synopsis

The remote host is affected by a remote code execution vulnerability.

Description

The version of Kibana installed on the remote host is 9.0.x prior to 9.4.9, or 9.5.x prior to 9.5.6. It is, therefore, affected by a vulnerability as referenced in the ESA-2026-232 advisory.

- A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1. (CVE-2026-111497)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Kibana version 9.4.9, or 9.5.6 or later as appropriate for your release branch.

See Also

https://discuss.elastic.co/t/391369

Plugin Details

Severity: Critical

ID: 375645

File Name: kibana_esa_2026_232.nasl

Version: 1.1

Type: Remote

Family: CGI abuses

Published: 11/3/2026

Updated: 11/3/2026

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Critical

Score: 9.4

Percentile: 99.83

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-111497

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

CVSS v4

Risk Factor: Critical

Base Score: 9.2

Threat Score: 9.2

Threat Vector: CVSS:4.0/E:A

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

CPE: cpe:/a:elasticsearch:kibana

Required KB Items: installed_sw/Kibana

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/3/2026

Vulnerability Publication Date: 10/21/2026

CISA Known Exploited Vulnerability Due Dates: 11/10/2026

Reference Information

CVE: CVE-2026-111497