Elasticsearch 9.0.x < 9.4.9 / 9.5.x < 9.5.6 DoS (ESA-2026-201)

high Nessus Plugin ID 375644

Synopsis

The remote host is missing a security update.

Description

The version of Elasticsearch installed on the remote host is 9.0.x prior to 9.4.9, or 9.5.x prior to 9.5.6. It is, therefore, affected by a vulnerability as referenced in the ESA-2026-201 advisory.

- Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to denial of service via Serialized Data with Nested Payloads (CAPEC-230). An unauthenticated attacker with network access to the remote cluster server interface of a node can send a specially crafted request that causes the node to terminate. No credentials are required. The attacker can repeat the request against each reachable node. (CVE-2026-115290)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Elasticsearch version 9.4.9, or 9.5.6 or later as appropriate for your release branch.

See Also

https://discuss.elastic.co/t/391356

Plugin Details

Severity: High

ID: 375644

File Name: elasticsearch_esa_2026_201.nasl

Version: 1.1

Type: Combined

Agent: unix

Family: Misc.

Published: 11/3/2026

Updated: 11/3/2026

Configuration: Enable thorough checks (optional)

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.75

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-115290

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:elastic:elasticsearch, cpe:/a:elasticsearch:elasticsearch

Required KB Items: installed_sw/Elasticsearch

Exploit Ease: No known exploits are available

Patch Publication Date: 11/3/2026

Vulnerability Publication Date: 11/3/2026

Reference Information

CVE: CVE-2026-115290