nginx 0.8.11 < 1.30.4 / 1.31.x < 1.31.3 Use-After-Free Memory Corruption

high Nessus Plugin ID 375492

Synopsis

The remote web server is affected by a use-after-free memory corruption vulnerability.

Description

According to its Server response header, the installed version of nginx is 0.8.11 prior to 1.30.4 or 1.31.x prior to 1.31.3. It is, therefore, affected by the following issue :

- NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssi_module module. This vulnerability may exist when the Server-Side Includes (SSI), proxy_pass, and proxy_buffering off directives are configured. With this configuration, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to cause a use-after-free in the NGINX worker process. This issue may lead to limited modification of memory or a restart of the NGINX worker process. Impact: This vulnerability may allow remote attackers to have limited control to modify memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. (CVE-2026-56434)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to nginx 1.30.4 or 1.31.3 or later.

See Also

https://my.f5.com/manage/s/article/K000162098

https://nginx.org/en/security_advisories.html

https://www.cve.org/CVERecord?id=CVE-2026-56434

Plugin Details

Severity: High

ID: 375492

File Name: nginx-CVE-2026-56434.nasl

Version: 1.1

Type: Combined

Agent: unix

Family: Web Servers

Published: 11/3/2026

Updated: 11/3/2026

Configuration: Enable paranoid mode

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

Percentile: 95.96

CVSS v2

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:C

CVSS Score Source: CVE-2026-56434

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.3

Threat Score: 4.8

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

CPE: cpe:/a:nginx:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 7/15/2026

Reference Information

CVE: CVE-2026-56434

IAVA: 2026-A-0754