IBM MQ 9.4.0.0 < 9.4.0.30 LTS / 9.4.1.0 < 9.4.5.4 CD / 10.0.0.0 < 10.0.0.6 (7284695)

high Nessus Plugin ID 374145

Synopsis

The remote host is affected by a vulnerability.

Description

The version of IBM MQ Server running on the remote host is 9.4.0.0 through 9.4.0.26 LTS, 9.4.1.0 through 9.4.5.3 CD, or 10.0.0.0 through 10.0.0.5. It is, therefore, affected by a vulnerability as referenced in the 7284695 advisory.

- IBM MQ could allow an authenticated attacker to cause a denial of service or potentially execute arbitrary code due to a heap buffer overflow when processing MQPUT operations with malformed message options. (CVE-2026-10572)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to IBM MQ 9.4.0.30 LTS, 9.4.5.4 CD, 10.0.0.6 or later.

See Also

https://www.ibm.com/support/pages/node/7284695

Plugin Details

Severity: High

ID: 374145

File Name: ibm_mq_7284695.nasl

Version: 1.2

Type: Local

Agent: windows, macosx, unix

Family: Misc.

Published: 10/30/2026

Updated: 10/30/2026

Configuration: Enable thorough checks (optional)

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Tenable Cloud Security, Tenable Self-Hosted Container Security, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.51

CVSS v2

Risk Factor: High

Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-10572

CVSS v3

Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:ibm:mq, cpe:/a:ibm:websphere_mq

Required KB Items: installed_sw/IBM WebSphere MQ

Patch Publication Date: 10/23/2026

Vulnerability Publication Date: 10/19/2026

Reference Information

CVE: CVE-2026-10572

IAVA: 2026-A-1208