Mandriva Linux Security Advisory : libxslt (MDVSA-2008:151)

High Nessus Plugin ID 37284


The remote Mandriva Linux host is missing one or more security updates.


A buffer overflow vulnerability in libxslt could be exploited via an XSL style sheet file with a long XLST transformation match condition, which could possibly lead to the execution of arbitrary code (CVE-2008-1767).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 37284

File Name: mandriva_MDVSA-2008-151.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64xslt-devel, p-cpe:/a:mandriva:linux:lib64xslt1, p-cpe:/a:mandriva:linux:lib64xslt1-devel, p-cpe:/a:mandriva:linux:libxslt-devel, p-cpe:/a:mandriva:linux:libxslt-proc, p-cpe:/a:mandriva:linux:libxslt1, p-cpe:/a:mandriva:linux:libxslt1-devel, p-cpe:/a:mandriva:linux:python-libxslt, cpe:/o:mandriva:linux:2007.1, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/07/21

Reference Information

CVE: CVE-2008-1767

BID: 29312

MDVSA: 2008:151

CWE: 119