Mandriva Linux Security Advisory : mpg123 (MDVSA-2009:093-1)

Critical Nessus Plugin ID 37134


The remote Mandriva Linux host is missing a security update.


A vulnerability has been found and corrected in mpg123 :

Integer signedness error in the store_id3_text function in the ID3v2 code in mpg123 before 1.7.2 allows remote attackers to cause a denial of service (out-of-bounds memory access) and possibly execute arbitrary code via an ID3 tag with a negative encoding value. NOTE:
some of these details are obtained from third-party information (CVE-2009-1301).

The updated packages have been patched to correct this issue.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers


Update the affected mpg123 package.

Plugin Details

Severity: Critical

ID: 37134

File Name: mandriva_MDVSA-2009-093.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2009/04/23

Modified: 2014/04/24

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mpg123, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/08

Reference Information

CVE: CVE-2009-1301

BID: 34381

MDVSA: 2009:093-1

CWE: 189