Mandriva Linux Security Advisory : perl (MDVSA-2008:165)

Medium Nessus Plugin ID 37106


The remote Mandriva Linux host is missing one or more security updates.


The rmtree function in lib/File/ in Perl 5.10 does not properly check permissions before performing a chmod, which allows local users to modify the permissions of arbitrary files via a symlink attack.

The updated packages have been patched to fix this.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 37106

File Name: mandriva_MDVSA-2008-165.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:perl, p-cpe:/a:mandriva:linux:perl-base, p-cpe:/a:mandriva:linux:perl-devel, p-cpe:/a:mandriva:linux:perl-doc, p-cpe:/a:mandriva:linux:perl-suid, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/08/11

Reference Information

CVE: CVE-2008-2827

MDVSA: 2008:165

CWE: 264