Mandriva Linux Security Advisory : gnumeric (MDVSA-2008:056)

High Nessus Plugin ID 37027


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability was found in the excel_read_HLINK function in the Microsoft Excel plugin in Gnumeric prior to version 1.8.1 that would allow for the execution of arbitrary code via a crafted XLS file containing XLS HLINK opcodes.

The updated packages have been patched to correct this issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 37027

File Name: mandriva_MDVSA-2008-056.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnumeric, p-cpe:/a:mandriva:linux:lib64spreadsheet1.7.12, p-cpe:/a:mandriva:linux:lib64spreadsheet1.7.12-devel, p-cpe:/a:mandriva:linux:lib64spreadsheet1.7.8, p-cpe:/a:mandriva:linux:lib64spreadsheet1.7.8-devel, p-cpe:/a:mandriva:linux:libspreadsheet1.7.12, p-cpe:/a:mandriva:linux:libspreadsheet1.7.12-devel, p-cpe:/a:mandriva:linux:libspreadsheet1.7.8, p-cpe:/a:mandriva:linux:libspreadsheet1.7.8-devel, cpe:/o:mandriva:linux:2007.1, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/02/29

Reference Information

CVE: CVE-2008-0668

MDVSA: 2008:056

CWE: 189