Mandriva Linux Security Advisory : policykit (MDVSA-2008:087)

Medium Nessus Plugin ID 36964


The remote Mandriva Linux host is missing one or more security updates.


A format string vulnerability in the grant helper, in PolicyKit 0.7 and earlier, allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via format strings in a password.

The updated package has been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 36964

File Name: mandriva_MDVSA-2008-087.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64polkit-devel, p-cpe:/a:mandriva:linux:lib64polkit2, p-cpe:/a:mandriva:linux:libpolkit-devel, p-cpe:/a:mandriva:linux:libpolkit2, p-cpe:/a:mandriva:linux:policykit, p-cpe:/a:mandriva:linux:policykit-docs, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/04/16

Reference Information

CVE: CVE-2008-1658

MDVSA: 2008:087

CWE: 134