Mandrake Linux Security Advisory : wpa_supplicant (MDKSA-2007:245)

High Nessus Plugin ID 36831


The remote Mandrake Linux host is missing one or more security updates.


Stack-based buffer overflow in driver_wext.c in wpa_supplicant 0.6.0 allows remote attackers to cause a denial of service (crash) via crafted TSF data.

Updated package fixes this issue.


Update the affected wpa_gui and / or wpa_supplicant packages.

Plugin Details

Severity: High

ID: 36831

File Name: mandrake_MDKSA-2007-245.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2009/04/23

Modified: 2014/06/04

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:wpa_gui, p-cpe:/a:mandriva:linux:wpa_supplicant, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/12/13

Reference Information

CVE: CVE-2007-6025

MDKSA: 2007:245

CWE: 119