Ubuntu 6.06 LTS / 7.10 : evolution-data-server vulnerability (USN-733-1)

High Nessus Plugin ID 36746

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

It was discovered that the Base64 encoding functions in evolution-data-server did not properly handle large strings. If a user were tricked into opening a specially crafted image file, or tricked into connecting to a malicious server, an attacker could possibly execute arbitrary code with user privileges.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/733-1/

Plugin Details

Severity: High

ID: 36746

File Name: ubuntu_USN-733-1.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2009/04/23

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:evolution-data-server, p-cpe:/a:canonical:ubuntu_linux:evolution-data-server-common, p-cpe:/a:canonical:ubuntu_linux:evolution-data-server-dbg, p-cpe:/a:canonical:ubuntu_linux:evolution-data-server-dev, p-cpe:/a:canonical:ubuntu_linux:libcamel1.2-10, p-cpe:/a:canonical:ubuntu_linux:libcamel1.2-8, p-cpe:/a:canonical:ubuntu_linux:libcamel1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libebook1.2-5, p-cpe:/a:canonical:ubuntu_linux:libebook1.2-9, p-cpe:/a:canonical:ubuntu_linux:libebook1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libecal1.2-3, p-cpe:/a:canonical:ubuntu_linux:libecal1.2-7, p-cpe:/a:canonical:ubuntu_linux:libecal1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libedata-book1.2-2, p-cpe:/a:canonical:ubuntu_linux:libedata-book1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libedata-cal1.2-1, p-cpe:/a:canonical:ubuntu_linux:libedata-cal1.2-6, p-cpe:/a:canonical:ubuntu_linux:libedata-cal1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libedataserver1.2-7, p-cpe:/a:canonical:ubuntu_linux:libedataserver1.2-9, p-cpe:/a:canonical:ubuntu_linux:libedataserver1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libedataserverui1.2-6, p-cpe:/a:canonical:ubuntu_linux:libedataserverui1.2-8, p-cpe:/a:canonical:ubuntu_linux:libedataserverui1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libegroupwise1.2-13, p-cpe:/a:canonical:ubuntu_linux:libegroupwise1.2-9, p-cpe:/a:canonical:ubuntu_linux:libegroupwise1.2-dev, p-cpe:/a:canonical:ubuntu_linux:libexchange-storage1.2-1, p-cpe:/a:canonical:ubuntu_linux:libexchange-storage1.2-3, p-cpe:/a:canonical:ubuntu_linux:libexchange-storage1.2-dev, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:7.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/03/16

Reference Information

CVE: CVE-2009-0587

BID: 34100

USN: 733-1

CWE: 189