Mandriva Linux Security Advisory : kdelibs (MDVSA-2008:097)

Medium Nessus Plugin ID 36729


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability was found in start_kdeinit in KDE 3.5.5 through 3.5.9 where, if it was installed setuid root, it could allow local users to cause a denial of service or possibly execute arbitrary code (CVE-2008-1671).

By default, start_kdeinit is not installed setuid root on Mandriva Linux, however updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 36729

File Name: mandriva_MDVSA-2008-097.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:kdelibs-common, p-cpe:/a:mandriva:linux:kdelibs-devel-doc, p-cpe:/a:mandriva:linux:lib64kdecore4, p-cpe:/a:mandriva:linux:lib64kdecore4-devel, p-cpe:/a:mandriva:linux:libkdecore4, p-cpe:/a:mandriva:linux:libkdecore4-devel, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/05/06

Reference Information

CVE: CVE-2008-1671

MDVSA: 2008:097

CWE: 16